Skip to main content
HIGHCVE-2026-53488GHSA-xhf5-7wjv-pqxp
Affected projects
containerd
Disclosed
Last updated

Affected versions

ProjectVulnerable range
github.com/containerd/containerd>= 1.7.0, < 1.7.33
github.com/containerd/containerd>= 2.0.0, < 2.0.10
github.com/containerd/containerd>= 2.1.0, < 2.1.9
github.com/containerd/containerd>= 2.2.0, < 2.2.5
github.com/containerd/containerd>= 2.3.0, < 2.3.2

Patched versions

ProjectFixed in
github.com/containerd/containerd1.7.33
github.com/containerd/containerd2.0.10
github.com/containerd/containerd2.1.9
github.com/containerd/containerd2.2.5
github.com/containerd/containerd2.3.2

References

Summary​

A bug in containerd's CRI plugin causes labels from an image configuration (LABEL instructions in a Dockerfile) to be propagated to a container without validation. Any plugin that consumes container labels for operational purposes can be induced to execute the label's value as an arbitrary command on the host, with the privileges of the containerd process.

Impact​

An attacker who can influence the images used by a cluster node — whether by supplying a crafted image or by compromising an upstream registry — can embed malicious LABEL values that, when consumed by a label-processing plugin on the node, result in arbitrary command execution on the host. This constitutes a container escape path that does not require exploiting the container runtime directly. The vulnerability affects containerd v1.7.0 through v1.7.32 and all v2.x releases prior to their respective patched versions, making it a broad impact across deployments using affected containerd versions. Ensuring only trusted images are used is the primary workaround.

Detection​

Nodes running containerd v1.7.0–v1.7.32, v2.0.0–v2.0.9, v2.1.0–v2.1.8, v2.2.0–v2.2.4, or v2.3.0–v2.3.1 are in the affected version range. Verify the running version:

containerd --version

Audit node processes for unexpected commands spawned by containerd or any plugin that processes container labels. Review image provenance and admission controls to ensure only trusted registries are allowed.

Mitigation​

Upgrade to one of the patched containerd releases:

  • containerd v1.7.x: upgrade to v1.7.33 or later
  • containerd v2.0.x: upgrade to v2.0.10 or later
  • containerd v2.1.x: upgrade to v2.1.9 or later
  • containerd v2.2.x: upgrade to v2.2.5 or later
  • containerd v2.3.x: upgrade to v2.3.2 or later

As a workaround, ensure that only trusted images are used. Enforce image admission controls (such as Kyverno or OPA Gatekeeper policies) to restrict image sources to known-good registries, and audit installed containerd plugins for any that consume container labels for privileged operations.

References​